$re = '/\b[a-z]{1,4}\d{1,4}(?<=\b[a-z\d]{5})/m';
$str = 'a1111
aa111
aaa11b
aaaa1 x
a1a1a
aa11a
aa11
1aaaa x';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);