using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-z]{1,4}\d{1,4}(?<=\b[a-z\d]{5})";
string input = @"a1111
aa111
aaa11b
aaaa1 x
a1a1a
aa11a
aa11
1aaaa x";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}