re = /\b[a-z]{1,4}\d{1,4}(?<=\b[a-z\d]{5})/m
str = 'a1111
aa111
aaa11b
aaaa1 x
a1a1a
aa11a
aa11
1aaaa x'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end