using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(text1|text2).*?(?=\1|$)";
string input = @"Если в регулярном выражении (text1|text2), было совпадение с text1, то совпадения с text2 не проверялись. Но если text1 не найден, то искались совпадения с text2. ";
RegexOptions options = RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}