import re
regex = re.compile(r"(text1|text2).*?(?=\1|$)", flags=re.DOTALL)
test_str = "Если в регулярном выражении (text1|text2), было совпадение с text1, то совпадения с text2 не проверялись. Но если text1 не найден, то искались совпадения с text2. "
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")