const regex = new RegExp('(text1|text2).*?(?=\\1|$)', 'gs')
const str = `Если в регулярном выражении (text1|text2), было совпадение с text1, то совпадения с text2 не проверялись. Но если text1 не найден, то искались совпадения с text2. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}