$re = '~(text1|text2).*?(?=\1|$)~s';
$str = 'Если в регулярном выражении (text1|text2), было совпадение с text1, то совпадения с text2 не проверялись. Но если text1 не найден, то искались совпадения с text2. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);