$re = '/tppabs=".+"/';
$str = 'abcd tppabs="http://phpbbex.com/oldies/oldies.js" foo
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);