re = /tppabs=".+"/
str = 'abcd tppabs="http://phpbbex.com/oldies/oldies.js" foo
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end