// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"static/css/.*.css").unwrap();
let string = "/static/css/style.css
/static/css/caca.css
/static/js/style.js
/static/js/caca.js";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}