#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:\t|^)\d+\K,(?=\d+(?:\t|$))"
Local $sString = "text, text bla 23,89 bla 0,5 bla" & @CRLF & _
"Blablabla 2325,8 869,4142 Blablabla" & @CRLF & _
"Blablabla 17,3 8,58 Blablabla" & @CRLF & _
"" & @CRLF & _
"23,89" & @CRLF & _
", " & @CRLF & _
"1," & @CRLF & _
",2" & @CRLF & _
"1,3 2,3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")