const regex = /(?:\t|^)\d+\K,(?=\d+(?:\t|$))/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\t|^)\\d+\\K,(?=\\d+(?:\\t|$))', 'gmi')
const str = `text, text bla 23,89 bla 0,5 bla
Blablabla 2325,8 869,4142 Blablabla
Blablabla 17,3 8,58 Blablabla
23,89
,
1,
,2
1,3 2,3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}