use strict;
my $str = 'text, text bla 23,89 bla 0,5 bla
Blablabla 2325,8 869,4142 Blablabla
Blablabla 17,3 8,58 Blablabla
23,89
,
1,
,2
1,3 2,3';
my $regex = qr/(?:\t|^)\d+\K,(?=\d+(?:\t|$))/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}