re = /(?:\t|^)\d+\K,(?=\d+(?:\t|$))/mi
str = 'text, text bla 23,89 bla 0,5 bla
Blablabla 2325,8 869,4142 Blablabla
Blablabla 17,3 8,58 Blablabla
23,89
,
1,
,2
1,3 2,3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end