use strict;
my $str = '1 : A
2 : B
3 : C
';
my $regex = qr/^(?!Line:)/mp;
my $subst = 'Line:';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";