#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<!\d)(?!0\d)\d{0,3}\.\d+)(?:\h+\S){0,6}\h+((?<!\d)(?!0\d)\d{0,3}\.\d+)"
Local $sString = "999.9 999.0" & @CRLF & _
"1.0 a a 2 a a a 1.0" & @CRLF & _
"-1.0 1.0" & @CRLF & _
"1.0 2.0 3.0" & @CRLF & _
"" & @CRLF & _
"2.0" & @CRLF & _
"999.9 1000.0" & @CRLF & _
"1.0 a a a 2 a a a 1.0" & @CRLF & _
"-1.0 -1.0" & @CRLF & _
"999 999.0" & @CRLF & _
"0100.0 100.0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")