using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<!\d)(?!0\d)\d{0,3}\.\d+)(?:\h+\S){0,6}\h+((?<!\d)(?!0\d)\d{0,3}\.\d+)";
string input = @"999.9 999.0
1.0 a a 2 a a a 1.0
-1.0 1.0
1.0 2.0 3.0
2.0
999.9 1000.0
1.0 a a a 2 a a a 1.0
-1.0 -1.0
999 999.0
0100.0 100.0";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}