$re = '/((?<!\d)(?!0\d)\d{0,3}\.\d+)(?:\h+\S){0,6}\h+((?<!\d)(?!0\d)\d{0,3}\.\d+)/m';
$str = '999.9 999.0
1.0 a a 2 a a a 1.0
-1.0 1.0
1.0 2.0 3.0
2.0
999.9 1000.0
1.0 a a a 2 a a a 1.0
-1.0 -1.0
999 999.0
0100.0 100.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);