import Foundation
let pattern = #"((?<!\d)(?!0\d)\d{0,3}\.\d+)(?:\h+\S){0,6}\h+((?<!\d)(?!0\d)\d{0,3}\.\d+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
999.9 999.0
1.0 a a 2 a a a 1.0
-1.0 1.0
1.0 2.0 3.0
2.0
999.9 1000.0
1.0 a a a 2 a a a 1.0
-1.0 -1.0
999 999.0
0100.0 100.0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)