import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((10|127)(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|169\\.254|192\\.168|172\\.(2[0-9]|1[6-9]|3[0-1]))(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){2}$";
final String string = "Private ranges\n"
+ "10.0.0.0-10.255.255.255\n"
+ "127.0.0.0-127.255.255.255\n"
+ "169.254.0.0-169.254.255.255\n"
+ "172.16.0.0-172.31.255.255\n"
+ "192.168.0.0-192.168.255.255\n\n\n"
+ "-----OK-----\n"
+ "10.0.0.0\n"
+ "10.255.255.255\n"
+ "127.0.0.0\n"
+ "127.255.255.255\n"
+ "169.254.0.255\n"
+ "169.254.255.255\n"
+ "172.16.0.0\n"
+ "172.31.255.255\n"
+ "192.168.0.0\n"
+ "192.168.255.255\n"
+ "------NOT OK------\n"
+ "1.1.1.1\n"
+ "9.255.255.255\n"
+ "11.0.0.0\n"
+ "126.255.255.255\n"
+ "128.0.0.0\n"
+ "169.253.255.255\n"
+ "169.255.0.0\n"
+ "172.15.255.255\n"
+ "172.32.0.0\n"
+ "192.167.255.255\n"
+ "192.169.0.0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}