const regex = /^((10|127)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|169\.254|192\.168|172\.(2[0-9]|1[6-9]|3[0-1]))(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){2}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((10|127)(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|169\\.254|192\\.168|172\\.(2[0-9]|1[6-9]|3[0-1]))(\\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){2}$', 'gm')
const str = `Private ranges
10.0.0.0-10.255.255.255
127.0.0.0-127.255.255.255
169.254.0.0-169.254.255.255
172.16.0.0-172.31.255.255
192.168.0.0-192.168.255.255
-----OK-----
10.0.0.0
10.255.255.255
127.0.0.0
127.255.255.255
169.254.0.255
169.254.255.255
172.16.0.0
172.31.255.255
192.168.0.0
192.168.255.255
------NOT OK------
1.1.1.1
9.255.255.255
11.0.0.0
126.255.255.255
128.0.0.0
169.253.255.255
169.255.0.0
172.15.255.255
172.32.0.0
192.167.255.255
192.169.0.0`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}