use strict;
my $str = 'Private ranges
10.0.0.0-10.255.255.255
127.0.0.0-127.255.255.255
169.254.0.0-169.254.255.255
172.16.0.0-172.31.255.255
192.168.0.0-192.168.255.255
-----OK-----
10.0.0.0
10.255.255.255
127.0.0.0
127.255.255.255
169.254.0.255
169.254.255.255
172.16.0.0
172.31.255.255
192.168.0.0
192.168.255.255
------NOT OK------
1.1.1.1
9.255.255.255
11.0.0.0
126.255.255.255
128.0.0.0
169.253.255.255
169.255.0.0
172.15.255.255
172.32.0.0
192.167.255.255
192.169.0.0';
my $regex = qr/^((10|127)(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?))|169\.254|192\.168|172\.(2[0-9]|1[6-9]|3[0-1]))(\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)){2}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}