import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "iPhone.*";
final String string = "iPhone 8\n"
+ "iPhone X\n"
+ "iPhone 11\n"
+ "iPhone 12\n"
+ "iPhone 13\n"
+ "iPhone 6\n"
+ "iPhone 7\n"
+ "iPhone 8\n"
+ "iPhone SE\n"
+ "iPhone 12 Pro\n"
+ "iPhone 14\n"
+ "iPhone 12 mini\n"
+ "iPhone 11 Pro Max\n"
+ "iPhone 12 Pro Max\n"
+ "iPhone XS\n"
+ "iPhone 13 Pro\n"
+ "iPhone 6S\n"
+ "iPhone 8 Plus\n"
+ "iPhone 13 Mini\n"
+ "iPhone 11 Pro\n"
+ "iPhone XS Max\n"
+ "iPhone 13 Pro Max\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}