use strict;
my $str = 'iPhone 8
iPhone X
iPhone 11
iPhone 12
iPhone 13
iPhone 6
iPhone 7
iPhone 8
iPhone SE
iPhone 12 Pro
iPhone 14
iPhone 12 mini
iPhone 11 Pro Max
iPhone 12 Pro Max
iPhone XS
iPhone 13 Pro
iPhone 6S
iPhone 8 Plus
iPhone 13 Mini
iPhone 11 Pro
iPhone XS Max
iPhone 13 Pro Max
';
my $regex = qr/iPhone.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}