import Foundation
let pattern = #"iPhone.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
iPhone 8
iPhone X
iPhone 11
iPhone 12
iPhone 13
iPhone 6
iPhone 7
iPhone 8
iPhone SE
iPhone 12 Pro
iPhone 14
iPhone 12 mini
iPhone 11 Pro Max
iPhone 12 Pro Max
iPhone XS
iPhone 13 Pro
iPhone 6S
iPhone 8 Plus
iPhone 13 Mini
iPhone 11 Pro
iPhone XS Max
iPhone 13 Pro Max
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)