$re = '/iPhone.*/m';
$str = 'iPhone 8
iPhone X
iPhone 11
iPhone 12
iPhone 13
iPhone 6
iPhone 7
iPhone 8
iPhone SE
iPhone 12 Pro
iPhone 14
iPhone 12 mini
iPhone 11 Pro Max
iPhone 12 Pro Max
iPhone XS
iPhone 13 Pro
iPhone 6S
iPhone 8 Plus
iPhone 13 Mini
iPhone 11 Pro
iPhone XS Max
iPhone 13 Pro Max
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);