using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S+) - - \[(\S+).*\] \""GET (.*?/)\s+";
string input = @"xx.xx.xx.xx - - [12/Jul/2018:19:29:43 +0800] ""GET /2018/07/06/antique-internet/ HTTP/1.1"" 200 5489 ""https://miscnote.net/"" ""Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}