// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(\S+) - - \[(\S+).*\] \"GET (.*?/)\s+"#).unwrap();
let string = "xx.xx.xx.xx - - [12/Jul/2018:19:29:43 +0800] \"GET /2018/07/06/antique-internet/ HTTP/1.1\" 200 5489 \"https://miscnote.net/\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36\"
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}