import re
regex = re.compile(r"^(\S+) - - \[(\S+).*\] \"GET (.*?/)\s+", flags=re.MULTILINE)
test_str = ("xx.xx.xx.xx - - [12/Jul/2018:19:29:43 +0800] \"GET /2018/07/06/antique-internet/ HTTP/1.1\" 200 5489 \"https://miscnote.net/\" \"Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/67.0.3396.99 Safari/537.36\"\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")