using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT(.+?)FROM INSERTED";
string input = @" SELECT
TOP(10)
CustomerID,
Name,
Address
FROM INSERTED i";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}