// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?sim)SELECT(.+?)FROM INSERTED").unwrap();
let string = " SELECT
TOP(10)
CustomerID,
Name,
Address
FROM INSERTED i";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}