re = /SELECT(.+?)FROM INSERTED/im
str = ' SELECT
TOP(10)
CustomerID,
Name,
Address
FROM INSERTED i'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end