package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sim)SELECT(.+?)FROM INSERTED`)
var str = ` SELECT
TOP(10)
CustomerID,
Name,
Address
FROM INSERTED i`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}