#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b([^:\n]*):\s*B"
Local $sString = "John SMith: A" & @CRLF & _
"Pedro Smith: B" & @CRLF & _
"Jonathan B: A" & @CRLF & _
"John B: B" & @CRLF & _
"Luis Diaz: A" & @CRLF & _
"Scarlet Diaz: B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")