import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b([^:\\n]*):\\s*B";
final String string = "John SMith: A\n"
+ "Pedro Smith: B\n"
+ "Jonathan B: A\n"
+ "John B: B\n"
+ "Luis Diaz: A\n"
+ "Scarlet Diaz: B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}