import re
regex = re.compile(r"\b([^:\n]*):\s*B", flags=re.MULTILINE)
test_str = ("John SMith: A\n"
"Pedro Smith: B\n"
"Jonathan B: A\n"
"John B: B\n"
"Luis Diaz: A\n"
"Scarlet Diaz: B")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")