#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"event_type=(?<event_type>\w[a-zA-Z-]+)\D+(?<size>\d*)"
Local $sString = "{"event_type":"event_type=adsad","size":"128844"}" & @CRLF & _
"{"event_type":"event_type=dsadsa","size":"388719"}" & @CRLF & _
"{"event_type":"event_type=blue","size":"1841504"}" & @CRLF & _
"{"event_type":"event_type=bluecoat","size":"221712725587"}" & @CRLF & _
"{"event_type":"event_type=casmdsad","size":"12356947232"}" & @CRLF & _
"{"event_type":"event_type=cisco-ddddd","size":"1553892585172"}" & @CRLF & _
"{"event_type":"event_type=cisco-edsd","size":"42949321020"}" & @CRLF & _
"{"event_type":"event_type=cyberark-dsds","size":"77274472"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")