import Foundation
let pattern = #""event_type=(?<event_type>\w[a-zA-Z-]+)\D+(?<size>\d*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
{"event_type":"event_type=adsad","size":"128844"}
{"event_type":"event_type=dsadsa","size":"388719"}
{"event_type":"event_type=blue","size":"1841504"}
{"event_type":"event_type=bluecoat","size":"221712725587"}
{"event_type":"event_type=casmdsad","size":"12356947232"}
{"event_type":"event_type=cisco-ddddd","size":"1553892585172"}
{"event_type":"event_type=cisco-edsd","size":"42949321020"}
{"event_type":"event_type=cyberark-dsds","size":"77274472"}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)