use strict;
my $str = '{"event_type":"event_type=adsad","size":"128844"}
{"event_type":"event_type=dsadsa","size":"388719"}
{"event_type":"event_type=blue","size":"1841504"}
{"event_type":"event_type=bluecoat","size":"221712725587"}
{"event_type":"event_type=casmdsad","size":"12356947232"}
{"event_type":"event_type=cisco-ddddd","size":"1553892585172"}
{"event_type":"event_type=cisco-edsd","size":"42949321020"}
{"event_type":"event_type=cyberark-dsds","size":"77274472"}';
my $regex = qr/"event_type=(?<event_type>\w[a-zA-Z-]+)\D+(?<size>\d*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}