#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?!^(?:\b(Example|Overflow|Test)\b(?!.*\b\1\b) *)+$)(?:\b(Example|Overflow|Test)\b(?!.*\b\2\b) *)+"
Local $sString = "Example Overflow Test Overflow" & @CRLF & _
"Example Overflow Test" & @CRLF & _
"Just an Example Overflow" & @CRLF & _
"Example another Overflow"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")