re = /(?!^(?:\b(Example|Overflow|Test)\b(?!.*\b\1\b) *)+$)(?:\b(Example|Overflow|Test)\b(?!.*\b\2\b) *)+/m
str = 'Example Overflow Test Overflow
Example Overflow Test
Just an Example Overflow
Example another Overflow'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end