using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^(?:\b(Example|Overflow|Test)\b(?!.*\b\1\b) *)+$)(?:\b(Example|Overflow|Test)\b(?!.*\b\2\b) *)+";
string input = @"Example Overflow Test Overflow
Example Overflow Test
Just an Example Overflow
Example another Overflow";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}