const regex = new RegExp('(?!^(?:\\b(Example|Overflow|Test)\\b(?!.*\\b\\1\\b) *)+$)(?:\\b(Example|Overflow|Test)\\b(?!.*\\b\\2\\b) *)+', 'gm')
const str = `Example Overflow Test Overflow
Example Overflow Test
Just an Example Overflow
Example another Overflow`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}