#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<verse>(?<block>^(?<num>\d+):\d+\s(?<txt>(?s).*?)(?<end>\n{2})(?!(?P=num)))+?)"
Local $sString = "1:10 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"1:11 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"2:20 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"2:21 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"2:22 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"3:30 foo bar" & @CRLF & _
"baz" & @CRLF & _
"" & @CRLF & _
"3:21 foo bar" & @CRLF & _
"baz" & @CRLF & _
""
Local $sSubst = "\n${verse}<br>\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)