use strict;
my $str = '1:10 foo bar
baz
1:11 foo bar
baz
2:20 foo bar
baz
2:21 foo bar
baz
2:22 foo bar
baz
3:30 foo bar
baz
3:21 foo bar
baz
';
my $regex = qr/(?<verse>(?<block>^(?<num>\d+):\d+\s(?<txt>(?s).*?)(?<end>\n{2})(?!(?P=num)))+?)/mp;
my $subst = '\\n${verse}<br>\\n\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";