import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<verse>(?<block>^(?<num>\\d+):\\d+\\s(?<txt>(?s).*?)(?<end>\\n{2})(?!(?P=num)))+?)";
final String string = "1:10 foo bar\n"
+ "baz\n\n"
+ "1:11 foo bar\n"
+ "baz\n\n"
+ "2:20 foo bar\n"
+ "baz\n\n"
+ "2:21 foo bar\n"
+ "baz\n\n"
+ "2:22 foo bar\n"
+ "baz\n\n"
+ "3:30 foo bar\n"
+ "baz\n\n"
+ "3:21 foo bar\n"
+ "baz\n";
final String subst = "\\n${verse}<br>\\n\\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}