const regex = /(?<verse>(?<block>^(?<num>\d+):\d+\s(?<txt>(?s).*?)(?<end>\n{2})(?!(?P=num)))+?)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<verse>(?<block>^(?<num>\\d+):\\d+\\s(?<txt>(?s).*?)(?<end>\\n{2})(?!(?P=num)))+?)', 'gm')
const str = `1:10 foo bar
baz
1:11 foo bar
baz
2:20 foo bar
baz
2:21 foo bar
baz
2:22 foo bar
baz
3:30 foo bar
baz
3:21 foo bar
baz
`;
const subst = `\n${verse}<br>\n\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);