import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9]\\B";
final String string = "Here is a test of some bullets \n"
+ "• Uno \n"
+ "• Two \n"
+ "• Tres \n"
+ "• Quarto \n"
+ "• Cinquo \n"
+ "Asdasasdas ";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}