# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^a-zA-Z0-9]\B"
test_str = ("Here is a test of some bullets \n"
"• Uno \n"
"• Two \n"
"• Tres \n"
"• Quarto \n"
"• Cinquo \n"
"Asdasasdas ")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.