package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\p{L}\p{N}-]+`)
var str = `abcd
ab-cd
müller
1248
ab99
straße
café
façade
São-Paulo
România
etc..
!
"
§
$
%
&
/
(
)
=
?
\`
>
°
^
_
<
|
#
'
@
,
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}